Running python on JASMIN

On the JASMIN analysis machines and on Lotus, we support the scientific Python packages under Python 2.7.

The default version of Python on the system is 2.6, which is used by the operating system. So to use the scientific packages, you need to invoke version 2.7 explicitly using the command python2.7. Then you will find that import numpy etc will work.

This should also be used when running a script, for example:
[you@jasmin-sci1 ~]$ python2.7 your_script.py

If you want to use an executable script (which can be invoked just by name), then the recommended line to put at the top of it would be:

#!/usr/bin/env python2.7

after which you can do:

[you@jasmin-sci1 ~]$ chmod 755 your_script.py
[you@jasmin-sci1 ~]$ ./your_script.py

Please note that the scientific software is not provided on the login gateway nodes. You first need to ssh to one of the analysis machines. For example:

[you@jasmin-login1 ~]$ ssh -X jasmin-sci2
...
[you@jasmin-sci2 ~]$ python2.7
...
>>> import numpy
>>>

Still need help? Contact Us Contact Us